Les principales commandes pour les commutateurs HP

HP logo

Configuration

  • Modèles de Switch : HP 5130-24G-4SFP+ EI JG932A, HP 5130-24G-SFP-4SFP+ EI JG933A

Commandes

  • Entrer en mode configuration globale (équivalent à conf t chez Cisco) :
<Switch> system-view
  • Annuler un parametre :
[Switch] undo stp enable
  • Paramétrer le nom :
[Switch] sysname Switch
  • Sauvegarder la configuration :
[Switch] save
[Switch] save force
  • Paramétrer l'ip du switch :
[Switch] interface vlan-interface 1
ip address 192.168.20.10 255.255.255.0
  • Paramétrer la passerelle par défaut :
[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.1.254
  • Redémarrer :
<Switch> reboot
  • Paramétrer une bannière de connexion :
[Switch] header legal "Configures the banner to be displayed before a user inputs the username and password to access the CLI"
[Switch] header motd "Configures the greeting banner to be displayed before the legal banner appears"

Display

  • Obtenir les informations sur le firmware et l'ordre de boot :
<Switch> display boot-loader
  • Afficher le numéro de série :
<Switch> display device manuinfo slot 1
  • Afficher les informations sur le périphérique :
<Switch> display device
<Switch> display system stable state
<Switch> display version
  • Afficher la table d'adresses mac :
<Switch> display mac-address

Comptes utilisateurs

Ancien (Comware 5)

  • Créer et configurer un compte utilisteur local admin avec les droits administrateur :
[Switch] local-user admin
[Switch-luser-manage-admin] password simple password
[Switch-luser-manage-admin] authorization-attribute level 3

Nouveau (Comware 7)

  • Créer et configurer un compte utilisteur local admin avec les droits administrateur :
[Switch] local-user admin
[Switch-luser-manage-admin] password
p@ssw0rd:p
p@ssw0rd:p
[Switch-luser-manage-admin] authorization-attribute user-role network-admin

SSH

  • Générer une clé rsa :
[Switch] public-key local create rsa
  • Activer le service ssh :
[Switch] ssh server enable
  • Désactiver ssh version 1 :
[Switch] undo ssh server compatible-ssh1x
  • Autorise l'utilisateur admin à se connecter à son compte à distance par SSH :
[Switch] local-user admin
[Switch-luser-manage-admin] service-type ssh

Spanning Tree

  • Activer le spanning tree :
[Switch] stp enable
  • Activer le mode RTSP :
[Switch] stp mode rtsp
  • Configurer le bridge priority :
[Switch] stp root primary
  • Afficher les informations stp :
<Switch> display stp

Sécurité

  • Définir un mdp pour l'accès à la console :
[Switch] line aux 0
[Switch-line-aux0] authentication-mode password
[Switch-line-aux0] set authentication password simple "password"
  • Paramétrer l'auto logoff :
[Switch] line aux 0
[Switch-line-aux0] idle-timeout "minutes" "seconds"
  • Définir un timeout de 120 secondes après 3 tentatives de mot de passe :
[Switch] password-control login-attempt 3 exceed lock-time 120
  • Désactiver telnet :
[Switch] no telnet server enable
  • Activer la vérification de complexité des mots de passes :
[Switch] password-control complexity user-name check
  • Spécifier le nombre minimum de types de composition du mot de passe (lettres, chiffres, symboles) :
[Switch] password-control composition type-number "type number"

NTP

  • Définir le serveur ntp :
[Switch] ntp-service unicast-server 192.168.1.100
  • Préciser dans quel vlan se trouve le serveur ntp (optionnel) :
[Switch] ntp-service source vlan-interface 10
  • Démarrer le service ntp :
[Switch] ntp-service enable
  • Afficher l'heure :
[Switch] show clock

VLAN et TRUNK

VLAN

  • Créer un VLAN et paramétrer son nom :
[Switch] vlan 10
[Switch-vlan10] name ADMIN
  • Associer un VLAN à une interface :
[Switch] interface GigabitEthernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type access
[Switch-GigabitEthernet1/0/1] port access vlan 10

Trunk

  • Configurer une interface TRUNK :
[Switch] interface GigabitEthernet 1/0/24
[Switch-GigabitEthernet1/0/24] port link-type trunk
[Switch-GigabitEthernet1/0/24] port trunk permit vlan 1 10

Mise à jour du Firmware

On peut récupérer les derniers firmwares à cette addresse : https://h10145.www1.hpe.com/downloads/

  • Copier le nouveau firmware d'un serveur tftp vers le switch HP :
<Switch> tftp TFTP_SERVER get FIRMWARE.ipe
  • Définir le nouveau firmware comme image de démarrage principal :
<Switch> boot-loader file flash:/FIRMWARE.ipe slot 1 main
  • Vérifier l'ordre de démarrage :
<Switch> display boot-loader
  • Redémarrer :
<Switch> reboot
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Contact :